CVE-2024-39877

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

CVSS base score
8.8 (v3.1)
Severity
HIGH
Attack vector
Network
Weakness
CWE-94, CWE-277
Last modified
November 3, 2026
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected products

apache airflow

References

View full NVD advisory →

More apache vulnerabilities

Published the same day

← Back to CVE watch