D-Link Nuclias Connect firmware versions <= 1.3.1.4 contain a stored cross-site scripting (XSS) vulnerability due to improper sanitization of the 'Network' field when editing the configuration, creating a profile, and adding a network. An authenticated attacker can inject arbitrary JavaScript to be executed in the context of other users viewing the profile entry. NOTE: D-Link fixed this issue in version 1.3.1.5.
CVE-2025-34253
CVSS base score
5.4 (v3.1)
Severity
MEDIUM
Attack vector
Network
Weakness
CWE-79
Last modified
October 29, 2026
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Affected products
dlink nuclias connect
References
- supportannouncement.us.dlink.com Vendor Advisory
- www.dlink.com Product
- www.vulncheck.com Third Party Advisory